summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2022-09-24 12:31:57 -0400
committerChris Severance2022-09-24 12:31:57 -0400
commit41b472e3e34034a5a0cfe71f78d73b864d4c15fb (patch)
treefb257b8c912d459eac217ae84dc86601f0b3ed5d /PKGBUILD
parentf31d16b5c7e831287afd793efa3f29da4491acbb (diff)
downloadaur-mt-st-git.tar.gz
autu: Update to 1.4.r10.gfbfd923-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39b9b2668c03..35d148287e0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,38 @@
set -u
_pkgname='mt-st'
pkgname="${_pkgname}-git"
-pkgver=1.1.r6.gece9c03
+pkgver=1.4.r10.gfbfd923
pkgrel=1
pkgdesc='Utilities for managing magnetic tape storage devices'
arch=('i686' 'x86_64')
-url="https://github.com/Distrotech/${_pkgname}"
+#url="https://github.com/Distrotech/${_pkgname}"
+url="https://github.com/iustin/${_pkgname}"
license=('GPLv2')
depends=('tar')
makedepends=('git')
provides=("${_pkgname}=${pkgver%.r*}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+${url}.git")
+source=("git+${url}.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
pkgver() {
set -u
cd "${_pkgname}"
- printf '%s.r%s.g%s' "$(sed -ne 's:^#define VERSION "\(.*\)"$:\1:p' "mt.c")" "$(git rev-list --count HEAD)" "$(git describe --always )" # '
+ #printf '%s.r%s.g%s' "$(sed -ne 's:^#define VERSION "\(.*\)"$:\1:p' "mt.c")" "$(git rev-list --count HEAD)" "$(git describe --always )" # '
+ git describe --long | sed -E -e 's/^v//' -e 's/[^-]+-g/r&/' -e 's/-/./g'
set +u
}
prepare() {
set -u
cd "${_pkgname}"
- sed -e 's:^#include <sys/types.h>$:#include <sys/sysmacros.h>\n&:g' -i 'mt.c'
+ #sed -e 's:^#include <sys/types.h>$:#include <sys/sysmacros.h>\n&:g' -i 'mt.c'
+ sed -E \
+ -e '/^SBINDIR=/ s:/sbin:/usr/bin:g' \
+ -e '/^BINDIR=/ s:/bin:/usr/bin:g' \
+ -e '/^COMPLETIONINSTALLDIR=/ s:/etc:/usr/share:g' \
+ -i 'Makefile'
set +u
}
@@ -42,9 +50,9 @@ build() {
package() {
set -u
cd "${_pkgname}"
- make DESTDIR="${pkgdir}" PREFIX='/usr' SBINDIR='/usr/bin' install
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/usr/bin/"{mt,mt-st}
+ mv "${pkgdir}/usr/share/man/man1/"{mt.1,mt-st.1}
set +u
}
set +u
-
-# vim:set ts=2 sw=2 et: