summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Westover2023-10-24 13:18:40 -0400
committerBen Westover2023-10-24 13:18:40 -0400
commitfdfb5ca2a8ad809c3660eb190ec0522ab76cdd3d (patch)
treecce7f8b92c8f9cb1a74a514404ed13b16069f4bd /PKGBUILD
parentf7d33cf39a2e0889ebaf0f3733d2b44a6cbad8e2 (diff)
downloadaur-mtkclient-git.tar.gz
Many fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86e37b0ccfb8..ac33444ffbb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Ben Westover <kwestover.kw@gmail.com>
pkgname=mtkclient-git
-pkgver=1.63.r6.g054dafa
+pkgver=1.63.r38.gb63c933
pkgrel=1
pkgdesc="Unofficial MTK reverse engineering and flash tool"
arch=('any')
url="https://github.com/bkerler/mtkclient"
-license=('GPL')
-depends=('libusb' 'python' 'python-pyusb' 'python-pyserial' 'python-pycryptodome' 'python-colorama' 'python-mock' 'shiboken6' 'pyside6')
+license=('GPL3')
+depends=('libusb' 'python' 'python-pyusb' 'python-pyserial' 'python-pycryptodome' 'python-pycryptodomex' 'python-colorama' 'python-mock' 'shiboken6' 'pyside6')
makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
conflicts=('mtkclient')
provides=('mtkclient')
-install=mtkclient.install
source=("git+https://github.com/bkerler/mtkclient.git"
- "usb.patch")
+ "scripts-and-data-files.patch"
+ "udev.patch")
sha256sums=('SKIP'
- '953b4111910056208b032573b0c34d886490efda06ada46f9718a70d15f891d2')
+ 'd156e692d36fb48f9d385598a2b888ddf3bf0fea182cf9757a71c971c144f710'
+ 'd4b6d7967324e585f69c51257e4293f390291a9534e697eefc94568d169220bc')
pkgver() {
cd mtkclient
@@ -24,8 +25,13 @@ pkgver() {
prepare() {
cd mtkclient
- # Remove problematic "usb" dependency (package already depends on pyusb)
- cat ../usb.patch | patch -p1
+
+ # Prevent LICENSE and README.md from being installed directly into /usr.
+ # Also add mtk_gui to list of scripts to be insalled into /usr/bin.
+ cat ../scripts-and-data-files.patch | patch -p1
+
+ # Replace plugdev with uaccess and adbusers like upstream android-udev
+ cat ../udev.patch | patch -p1
}
build() {
@@ -36,4 +42,5 @@ build() {
package() {
cd mtkclient
python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 Setup/Linux/51-edl.rules "$pkgdir/usr/lib/udev/rules.d/52-mtk-edl.rules"
}