summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM. Greyson Christoforo2023-11-25 23:56:49 -0700
committerM. Greyson Christoforo2023-11-25 23:56:49 -0700
commit97b600b9055a5fbf7d1b3b75d8ea616c82e239ec (patch)
treeb9544ee3fe58bfa5b2bd81458495a9cff4c8872e /PKGBUILD
downloadaur-mumps-cmake.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1af3f35cf5b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=mumps-cmake
+pkgver=5.6.2.2
+pkgrel=1
+pkgdesc='MUMPS via CMake'
+arch=('x86_64')
+url='https://github.com/scivision/mumps'
+license=('MIT')
+depends=(
+lapack
+openmpi
+scotch
+scalapack
+metis
+zlib
+bzip2
+)
+makedepends=(
+gcc-fortran
+cmake
+git
+ninja
+)
+provides=(mumps)
+conflicts=(mumps)
+
+_fragment="#tag=v${pkgver}"
+source=("git+https://github.com/scivision/mumps.git${_fragment}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd mumps
+}
+
+build() {
+ # TODO: stop this from downloading and put the source in the source array
+ cmake -B build_dir -S mumps -W no-dev -G Ninja \
+ -D CMAKE_BUILD_TYPE=None \
+ -D CMAKE_INSTALL_PREFIX='/usr'
+
+ cmake --build build_dir
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build_dir
+}