summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:03:56 -0400
committerKyle Keen2015-06-13 00:03:56 -0400
commit4c78a5f2b7490ba2e634d7da88a3a85fc0d317f5 (patch)
tree7bf9b5bc1ba6dc8d8ae4dd399eb1366352eb6eed /PKGBUILD
downloadaur-mythryl-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c29af8f614
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kyle Keen <keenerd@gmail.com>
+
+pkgname=mythryl-git
+pkgver=20100319
+pkgrel=1
+pkgdesc="A modern typesafe, threadsafe, stackless ML."
+url="http://mythryl.com/"
+arch=('i686') # might be able to do x86_64 with multilib
+license=('GPL3')
+depends=("gtk2" "gtkglext")
+makedepends=('git')
+conflicts=("mythryl")
+provides=("mythryl")
+source=('git://github.com/mythryl/mythryl.git')
+md5sums=('SKIP')
+
+_gitname="mythryl"
+
+pkgver() {
+ cd "$_gitname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd "$_gitname"
+ ./Configure
+ make compiler
+ #make rest
+}
+
+package() {
+ cd "$_gitname"
+ #make DESTDIR="$pkgdir" install
+ # No destdir, no prefix. Let's do it by hand!
+ install -d "$pkgdir/usr/bin/"
+ find bin/ -executable -type f | xargs install -Dm755 "$pkgdir/usr/bin/"
+}