summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrafcube2022-11-01 20:35:16 +0530
committerGrafcube2022-11-01 20:35:16 +0530
commitef99f893e2be6bbb26390e45dc0a2385b8296f43 (patch)
tree57704badda394df268db602afe64df4263b9279f /PKGBUILD
downloadaur-namedicon-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48d3cdabf833
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grafcube <grafcube at disroot dot org>
+
+_pkgname=namedicon
+pkgname=${_pkgname}-git
+pkgver=v1.0.0.r0.g1964aff
+pkgrel=1
+pkgdesc='Get system icons from the name using the default icon theme. '
+arch=('x86_64')
+url="https://codeberg.org/grafcube/${_pkgname}"
+license=('GPL')
+depends=('gtk3')
+makedepends=('git' 'zig')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ zig build -Drelease-safe
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 zig-out/bin/${_pkgname} "$pkgdir"/usr/bin/${_pkgname}
+}