summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkari-chan2021-04-19 20:43:03 +0300
committerAkari-chan2021-04-19 20:43:03 +0300
commitf2d3535157c444c81bf5d4da0bc3701531593658 (patch)
tree794193f30c475896df9ca64d43e9833e524f79a2 /PKGBUILD
downloadaur-namespaced-wireguard-vpn-git.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d2b1f7e0d5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Akari-chan <`echo bWkudnUuc2VkYWlAZ21haWwuY29tCg== | base64 -d`>
+# Upstream author: Chris Bouchard <https://github.com/chrisbouchard>
+
+pkgname=namespaced-wireguard-vpn-git
+_pkgname=namespaced-wireguard-vpn
+pkgver=r30.0ac54bb
+pkgrel=1
+
+pkgdesc='Systemd configuration for a network namespace containing a WireGuard VPN connection'
+url='https://github.com/chrisbouchard/namespaced-wireguard-vpn'
+arch=('any')
+license=('MIT')
+
+depends=('findutils' 'wireguard-tools' 'bash')
+makedepends=('git')
+
+source=("$pkgname::git+https://github.com/chrisbouchard/namespaced-wireguard-vpn")
+sha256sums=(SKIP)
+
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+backup=(etc/$_pkgname/namespaced-wireguard-vpn.conf)
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf 'r%s.%s\n' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -m 644 -D LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -m 644 -D README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+
+
+ # why not sbin: https://stackoverflow.com/a/51032471
+ install -m 755 -D -t "$pkgdir/usr/bin" bin/*
+
+ install -m 600 -D -t "$pkgdir/etc/$_pkgname" conf/*
+
+ install -m 644 -D -t "$pkgdir/usr/lib/systemd/system" systemd/*
+}