summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2017-11-18 20:35:16 -0200
committerTércio Martins2017-11-18 20:35:16 -0200
commita906643fddfdcd21bfc898550f416703d104695b (patch)
tree15a5ec8cbcdcab35d459b79ae5acbdd83ceafa0d /PKGBUILD
parent4676f7b4bac681a346cd0ed0cacede4bb5343ea7 (diff)
downloadaur-a906643fddfdcd21bfc898550f416703d104695b.tar.gz
Update to 2.3.3; reverting changes in the PKGBUILD file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 66 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56c311d86ce2..cdb86add7e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,71 @@
-# Maintainer: liberodark
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contributor: Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: liberodark
pkgname=natron
-pkgver=2.3.2
+pkgver=2.3.3
pkgrel=1
-pkgdesc="Cross platform open source compositing software."
-arch=('x86_64')
-url="https://github.com/MrKepzie/Natron"
-license=('GPL')
-depends=('fontconfig' 'qt4' 'python2-pyside' 'python2-shiboken' 'boost-libs' 'pixman' 'glfw-x11' 'cairo')
-optdepends=('openfx-io' 'openfx-misc' 'openfx-arena: Extra OpenFX plugins for Natron includes text node' 'openfx-gmic-bin' 'natron-plugins' 'firejail-extras: Run Natron with an isolated enviorment')
-source_x86_64=("https://github.com/liberodark/natron/releases/download/2.3.2/natron_2.3.2_amd64.deb")
-source=($pkgname.desktop
- $pkgname.png)
-sha512sums=('4670e936aaa48997d774ec4b13972f067a1bf5b0502cc4cdceef2cbbf308f7a670b09af4e7c80ccbfa398cf00c98d7446ee33a79af0d107750b2a13519539e46'
- '3a61fc234728bff85cd39690c3a49b5bd768e8382e538299e7171265560e49b97be6c2068862265c93be87b03fd3fb20f9470c898978184bf96d302b8bc1590d')
-sha512sums_x86_64=('8dabd93586d455e67c7c52864a6cc9e5b1a393ddbe33d29586c57a972a9cc721c62ef6eaf2edaef617d25263b212f3a546ab7ef49a0735e8da873da8587fd1e1')
-
+pkgdesc="Open source compositing software. Node-graph based. Similar in functionalities to Adobe After Effects and Nuke by The Foundry."
+arch=("i686" "x86_64")
+url="https://github.com/nyancat18/natron-arch"
+license=("GPL")
+depends=('fontconfig' 'qt4' 'python2-pyside' 'python2-shiboken' 'boost-libs' 'pixman' 'glfw-x11' 'cairo' 'openfx-io' 'openfx-misc')
+makedepends=('git' 'expat' 'boost')
+optdepends=('openfx-arena: Extra OpenFX plugins for Natron includes text node' 'natron-plugins' 'firejail-extras: Run Natron with an isolated enviorment')
+source=("$pkgname::git+https://github.com/MrKepzie/Natron.git#tag=$pkgver"
+ "git+https://github.com/devernay/openfx.git"
+ "git+https://github.com/MrKepzie/google-test.git"
+ "git+https://github.com/MrKepzie/google-mock.git"
+ "git+https://github.com/MrKepzie/SequenceParsing.git"
+ "git+https://github.com/MrKepzie/tinydir"
+ "https://github.com/MrKepzie/OpenColorIO-Configs/archive/Natron-v${pkgver%.*}.tar.gz"
+ "config.pri")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '42035f867188fcb7ec76f2f44a1d01b0c47bdc8aa94b22280e2691465ef135059e49ea5efa18d70c496b0319b8c888f3660ecbdb98bb5ba4a66d66dc77e21778'
+ '48017b7b9cd1854064b9ddffecedef89a4d38070f9a7d2cd506aad481a8061c5cffe5e5c84fc9b0ac5216fc99e093481db367e91ce52cb2a8a66223c4209402a')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ mv "$srcdir/OpenColorIO-Configs-Natron-v${pkgver%.*}" "$srcdir/$pkgname/OpenColorIO-Configs"
+
+ # Git submodules
+ git config submodule.libs/OpenFX.url $srcdir/openfx
+ git config submodule.Tests/google-mock.url $srcdir/google-mock
+ git config submodule.Tests/google-test.url $srcdir/google-test
+ git config submodule.libs/SequenceParsing.url $srcdir/SequenceParsing
+ git submodule update
+
+ cd libs/SequenceParsing
+ git config submodule.tinydir.url $srcdir/tinydir
+ git submodule update
+ cd ../..
+
+ mv "${srcdir}/config.pri" "${srcdir}/${pkgname%%-*}/config.pri"
+ # Fix for gcc{6,7} build issues
+ sed -i '1s/^/QMAKE_CXXFLAGS += -std=c++98\n/' Gui/Gui.pro
+ sed -i '1s/^/QMAKE_CXXFLAGS += -std=c++98\n/' Engine/Engine.pro
+ sed -i '1s/^/QMAKE_CXXFLAGS += -std=c++98\n/' Tests/Tests.pro
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ [[ -d build ]] && rm -r build; mkdir build; cd build
+
+ qmake-qt4 -r "$srcdir/natron/Project.pro" PREFIX=/usr CONFIG+=release DEFINES+=QT_NO_DEBUG_OUTPUT QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" QMAKE_LFLAGS_RELEASE="${LDFLAGS}"
+
+ make
+}
+
package() {
- cd $srcdir
- tar xvf data.tar.xz
- cp -r opt $pkgdir
- install -vDm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -vDm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ cd "$srcdir/$pkgname/build"
+ make INSTALL_ROOT="$pkgdir" install
}
+