summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlvxnull2024-02-28 00:19:02 +0100
committerlvxnull2024-02-28 00:19:02 +0100
commit3f6aae0b10f0712244750301f3f62259443f0ae4 (patch)
tree89db9054aebc93445214b80cd4fbc021eac3b027 /PKGBUILD
parent4cf701cd6b2aaa66f7d2be3b9779fd1e418e7ea9 (diff)
downloadaur-nautilus-open-any-terminal.tar.gz
Update to 0.5.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 11 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76e16e4e0bb0..ce937b256d93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,26 @@
# Maintainer: Felix Bühler <account at buehler dot de>
+# Maintainer: lvxnull <lvxnull at proton dot me>
pkgname=nautilus-open-any-terminal
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc="context-menu entry for opening other terminal in nautilus"
arch=(any)
url="https://github.com/Stunkymonkey/nautilus-open-any-terminal"
license=(GPL3)
depends=(python-nautilus)
-makedepends=(git python-setuptools)
-_commit=733cefb5269c9910606eef3df46f4e02c7726d43
-source=("git+https://github.com/Stunkymonkey/nautilus-open-any-terminal#commit=$_commit")
-sha512sums=("SKIP")
-
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
+makedepends=(make)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('1f66f7588c22486100e72e1efff96d7b2977ae05a05b14674417a143666c6a62')
build() {
- cd $pkgname
- python3 setup.py build
+ cd "${pkgname}-${pkgver}"
+
+ make build
}
package() {
- cd "${pkgname}"
-
- python3 setup.py install --root "${pkgdir}" --home /usr
+ cd "${pkgname}-${pkgver}"
- # Don't install the module
- rm -rf "${pkgdir}/usr/lib"
- find "${pkgdir}" -name "__pycache__" -type d -exec rm -rf {} +
+ make PREFIX="${pkgdir}/usr" install
}