summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlireza |S.N|2024-02-19 14:49:47 +0330
committerAlireza |S.N|2024-02-19 14:49:47 +0330
commit2693d0443c363609168a232cbcc21873d5bf0aee (patch)
tree1e65df26b773ff907c1188119129396609e7bd16 /PKGBUILD
parenta8ed6621e6b576412406a43d107d35a1ceff0a15 (diff)
downloadaur-nautilus-send-to-bluetooth.tar.gz
Apply improvements by 'Abraham S.A.H.<arash.sah@tuta.io>'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bb387ac38fa..cec4d3f899e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
+# Maintainer: Alireza S.N <alireza6677 at gmail dot com>
pkgname=nautilus-send-to-bluetooth
pkgver=2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Adds 'Send to bluetooth device' to nautilus right-click menu"
-arch=('any')
+arch=('x86_64')
url='https://github.com/alireza6677/nautilus-send-to-bluetooth'
-license=('GPL3')
-depends=( 'python' 'nautilus>=44' 'blueman' 'python-nautilus' 'bluez-obex')
+license=('GPL-3.0-or-later')
+depends=('python' 'nautilus>=44' 'blueman' 'python-nautilus' 'bluez-obex')
provides=("nautilus-send-to-bluetooth")
+source=("https://raw.githubusercontent.com/TheWeirdDev/nautilus-send-to-bluetooth/master/SendToBluetooth.py")
+noextract=('SendToBluetooth.py')
+b2sums=(SKIP)
package() {
- cd "${srcdir}/"
-
- install -d ${pkgdir}/usr/share/nautilus-python/extensions/
-
- cp -a ../SendToBluetooth.py ${pkgdir}/usr/share/nautilus-python/extensions/SendToBluetooth.py
+ cd $srcdir
+ install -Dm644 SendToBluetooth.py -t $pkgdir/usr/share/nautilus-python/extensions
}