summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosh Marshall2018-04-04 17:08:21 -0400
committerJosh Marshall2018-04-04 17:08:21 -0400
commit4ee9f97aee67753a4f02281b903548140e741bf0 (patch)
tree916248aea30f58b23966e3adfe0807c22773dcd1 /PKGBUILD
downloadaur-ncoils.tar.gz
Basic packaging of ncoils.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b64faeaf773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Josh Marshall <jrmarsha@mtu.edu>
+
+pkgname=ncoils
+pkgver='2.2.1'
+pkgrel=1
+pkgdesc="Rob Russell's attempt to make a COILS program"
+arch=('x86_64')
+license=('GPL')
+url='http://www.russelllab.org'
+depends=('glibc')
+makedepends=('gcc-libs')
+provides=()
+path='/coils'
+source=(
+ "$url$path/coils.tar.gz"
+)
+sha512sums=(
+'d10f2bfd7d8ea9062c49a805553c4109e06467fbe0f73c44b67ddf9f3224652112b46d6cfefdf29c1fea0505c732acf5e6bf7b30f90a7ec59a8cbbdc6422d829'
+)
+
+
+build() {
+ cd coils
+ cc -O2 -march=native -pipe -I. -o ncoils ncoils.c read_matrix.c -lm
+}
+
+package() {
+ cd coils
+ install -D ncoils "$pkgdir/usr/bin/ncoils"
+}