summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2020-12-13 17:25:17 -0500
committerMario Finelli2020-12-13 17:25:17 -0500
commit58ab62dcae1f5415853559fb08f3d0a765499e66 (patch)
tree5d559b829f0c2c0377e63f1f8bf4aeaa3b7e83b2 /PKGBUILD
parent1f9e3680bd86f3c6c8e4aca942116f4bc4b9c2da (diff)
downloadaur-ndsplus-git.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 21 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9121010d21eb..d62e28a13044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=ndsplus-git
pkgver=r8.93f517c
-pkgrel=2
-pkgdesc="Linux support for the EMS NDS Adapter+."
-arch=('i686' 'x86_64')
-url="https://github.com/Thulinma/ndsplus"
-license=('GPL')
-depends=('pkg-config' 'libusb')
-makedepends=('git')
-provides=('ndsplus')
-conflicts=('ndsplus')
-source=('git://github.com/Thulinma/ndsplus.git'
- 'ndsadapterplus.rules')
+pkgrel=3
+pkgdesc="Linux support for the EMS NDS Adapter+"
+arch=(i686 x86_64)
+url=https://github.com/Thulinma/ndsplus
+license=(GPL)
+depends=(pkg-config libusb)
+makedepends=(git)
+provides=(ndsplus)
+conflicts=(ndsplus)
+source=(git+https://github.com/Thulinma/ndsplus.git
+ ndsadapterplus.rules)
sha256sums=('SKIP'
'03fa9595fbb440bc4d78df2f4655eddb0ad29bc2f2860f2e0dd701a14601c9ac')
pkgver() {
- cd "$srcdir/ndsplus"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ndsplus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
-build(){
- cd "$srcdir/ndsplus"
+build() {
+ cd ndsplus
make
}
-package(){
- cd "$srcdir"
- install -Dm0644 ndsadapterplus.rules "$pkgdir"/etc/udev/rules.d/ndsadapterplus.rules
- cd "ndsplus"
- install -Dm0755 ndsplus "$pkgdir"/usr/bin/ndsplus
+package() {
+ install -Dm0755 ndsplus/ndsplus "$pkgdir/usr/bin/ndsplus"
+ install -Dm0644 ndsadapterplus.rules \
+ "$pkgdir/etc/udev/rules.d/ndsadapterplus.rules"
}