summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2019-10-31 22:48:28 +0100
committerAlad Wenter2019-10-31 22:48:28 +0100
commit555884d8ea260dfba7260ce14150c635e9836ae6 (patch)
treeeae5ace183e35ffda5818202675dcf5766f0797f /PKGBUILD
parentb2274dac37f07a9ac74b710c9b514efa5db7e0c8 (diff)
downloadaur-555884d8ea260dfba7260ce14150c635e9836ae6.tar.gz
neomutt-git: sync with community, update pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 219932e45404..61e34b08d8fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Chris Salzberg <chris@dejimata.com>
_pkgname=neomutt
pkgname=neomutt-git
-pkgver=20180716.r180.gb6a602e8a
+pkgver=20191025.r59.g3cd616659
pkgrel=1
pkgdesc='A version of mutt with added features - development branch'
url='http://www.neomutt.org/'
@@ -11,23 +11,24 @@ license=('GPL')
source=('git+https://github.com/neomutt/neomutt.git#branch=master')
sha256sums=('SKIP')
arch=('i686' 'x86_64')
-depends=('notmuch-runtime' 'lua')
+depends=('glibc' 'gpgme' 'lua' 'notmuch-runtime' 'krb5' 'openssl'
+ 'libsasl' 'ncurses' 'libidn2' 'lmdb' 'gdbm' 'kyotocabinet')
optdepends=('python: keybase.py')
-makedepends=('git' 'gnupg' 'libxslt' 'docbook-xsl' 'lynx')
+makedepends=('git' 'gnupg' 'libxslt' 'docbook-xsl' 'w3m')
conflicts=('neomutt')
provides=('neomutt')
pkgver() {
cd "$_pkgname"
- git describe --long --tags | sed 's/^neomutt-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed -r 's/(.*)-(.*)-/\1.r\2./; s/-//g'
}
build() {
cd "$_pkgname"
-
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --libexecdir=/usr/lib \
--gpgme \
--enable-lua \
--notmuch \
@@ -35,7 +36,11 @@ build() {
--ssl \
--sasl \
--with-ui=ncurses \
- --with-idn=/usr \
+ --with-idn2=/usr \
+ --idn=0 \
+ --idn2=1 \
+ --lmdb \
+ --kyotocabinet \
--gdbm
make
}