summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShane Stone2024-02-13 19:24:30 -0500
committerShane Stone2024-02-13 19:24:30 -0500
commitf07432ff91fe1d635d08226770c52d70cf79052d (patch)
tree0029d11b53946f4469f01e9f91bceef6dfd87427 /PKGBUILD
downloadaur-neovim-luasnip-opt-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9c44b9ed15f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=neovim-luasnip-opt-git
+_pkgname=luasnip
+pkgver=2076.2dbef19
+pkgrel=1
+pkgdesc='LuaSnip is a snippet-engine written entirely in lua.'
+arch=('any')
+url="https://github.com/L3MON4D3/${_pkgname}"
+license=('Apache')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rt "${pkgdir}/${_installpath}" doc ftplugin lua plugin syntax
+
+}