summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2023-07-07 12:34:59 +0200
committerStephanie Wilde-Hobbs2023-07-07 12:34:59 +0200
commit3d0594514aea740cf71d43beb7d8fc2d7ab2a94e (patch)
tree5a94f88a75c1ce8e4e66735e2ad9a2ce9278d791 /PKGBUILD
parent4b464dfb67127c50746d18aa550ca4b5cf47ce0f (diff)
downloadaur-netdata-git.tar.gz
fix build again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0fbd174b02a..82acee6a91cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=netdata-git
_gitname=netdata
-pkgver=v1.40.0.r10.ge12b0d8ab
+pkgver=v1.40.0.r101.g9a5a59885
pkgrel=1
pkgdesc="Real-time performance monitoring, in the greatest possible detail, over the web"
url="https://github.com/netdata/netdata/wiki"
@@ -31,12 +31,14 @@ source=("$_gitname::git+https://github.com/netdata/netdata"
"submodule-c-rbuf::git+https://github.com/underhood/c-rbuf.git"
"submodule-c_rhash::git+https://github.com/underhood/c_rhash.git"
"submodule-aclk-schemas::git+https://github.com/netdata/aclk-schemas.git"
+ "submodule-h2o::git+https://github.com/h2o/h2o.git"
"${_gitname}.sysusers")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'a910809a823ba58ca7bdaa72e8d68427b48f452c1fbb2343fa182ecb0a091a7640e73af24b8ba2fdd90e00aed8ef53b7fccd25cb8f04ca9b9fa6c8e52223ca66')
provides=('netdata')
conflicts=('netdata')
@@ -46,11 +48,14 @@ prepare() {
cd "$_gitname"
git submodule set-url mqtt_websockets "$srcdir"/submodule-mqtt_websockets
git submodule set-url aclk/aclk-schemas "$srcdir"/submodule-aclk-schemas
- git -c protocol.file.allow=always submodule update --init --no-fetch mqtt_websockets aclk/aclk-schemas
+ git submodule set-url web/server/h2o/libh2o "$srcdir"/submodule-h2o
+ git -c protocol.file.allow=always submodule update --init --no-fetch mqtt_websockets aclk/aclk-schemas web/server/h2o/libh2o
git -C mqtt_websockets submodule set-url c-rbuf "$srcdir"/submodule-c-rbuf
git -C mqtt_websockets submodule set-url c_rhash "$srcdir"/submodule-c_rhash
git -c protocol.file.allow=always -C mqtt_websockets submodule update --init --no-fetch c-rbuf c_rhash
+
+ sed -e 's|\# AX_CXX_COMPILE_STDCXX(17, noext, optional)|AX_CXX_COMPILE_STDCXX(17, noext, optional)|' -i configure.ac
}
pkgver() {
@@ -69,7 +74,7 @@ build() {
--sysconfdir="/etc" \
--libexecdir="/usr/lib" \
--localstatedir="/var" \
- --with-zlib --with-math --with-user=netdata --disable-httpd
+ --with-zlib --with-math --with-user=netdata
make
}