aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkXuan2021-08-17 20:44:01 +0800
committerkXuan2021-08-17 20:48:07 +0800
commit01e667fac6adb9cd3d70add8bcdac410d76c753f (patch)
tree40717a5dc4a182d9bc6974ad5e2f5136c78461f1 /PKGBUILD
parent0be3bfc0b05457fb7d96f165ca997ee083010b09 (diff)
downloadaur-01e667fac6adb9cd3d70add8bcdac410d76c753f.tar.gz
remove out-date dependencies
The library files packed in the .deb is made before 2019. These libraries are not compatible with arch linux. Some features are failed due to this reason. Such as unable using fcitx in the main program. This patch remove all libraries. So the netease main program can use libraries in the system. Signed-off-by: kXuan <kxuanobj@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d69115589149..8a55733f2a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,29 @@
pkgname=netease-cloud-music
pkgver=1.2.1
_pkgdate=20190428
-pkgrel=2
+pkgrel=3
pkgdesc="Netease Cloud Music, converted from .deb package"
arch=("x86_64")
url="https://music.163.com/"
license=('custom')
-depends=()
+depends=('qcef' 'vlc')
source=(
"https://d1.music.126.net/dmusic/netease-cloud-music_${pkgver}_amd64_ubuntu_${_pkgdate}.deb"
"https://music.163.com/html/web2/service.html"
+ "netease-cloud-music.bash"
)
md5sums=('1f47c7dc3d9ce46da8099e539ee8a74d'
- 'ee09cacb054f6a346bf935737df3f33d')
+ 'ee09cacb054f6a346bf935737df3f33d'
+ 'SKIP')
DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
package() {
cd ${srcdir}
- tar -xvf data.tar.xz -C ${pkgdir}
+ tar -xvf data.tar.xz -C ${pkgdir} \
+ ./opt/netease/netease-cloud-music/netease-cloud-music \
+ ./usr/share \
+ ./usr/bin/netease-cloud-music
install -D -m644 service.html ${pkgdir}/usr/share/licenses/$pkgname/license.html
+ install -D -m755 netease-cloud-music.bash ${pkgdir}/opt/netease/netease-cloud-music/netease-cloud-music.bash
}