summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan-Tarek Butt2020-12-31 13:33:32 +0100
committerJan-Tarek Butt2020-12-31 13:33:32 +0100
commit76629fee08626496b6103baccc3ba5451897859f (patch)
treef32abee581625b725e1b97ba9e41df5ffbb1a663 /PKGBUILD
parent89daf72712666db18b9397ed300aba934b5dc1d6 (diff)
downloadaur-76629fee08626496b6103baccc3ba5451897859f.tar.gz
PKGBUILD: fix source url and use sha256 instead of md5
Signed-off-by: Jan-Tarek Butt <tarek@ring0.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 9 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a59081e4ecf..b28610a20799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,30 @@
-# Maintainer: Swift Geek <swifgeek ɐŧ google bøt cøm>
-# Contributor: Nick Østergaard <oe.nick at gmail dot com>
-
-# TODO: move libs to lib32 ?
-# User lib32-gtk2 properly
-
-DLAGENTS=('http::/usr/bin/curl -d agree="We+luv+You" -fL -o %o %u')
+# Maintainer: Jan-Tarek Butt <tarek@ring0.de>
pkgname=netfabb-basic
pkgver=7.4.0
pkgrel=1
pkgdesc="view and repair STL files"
-arch=('i686' 'x86_64')
-url="http://www.netfabb.com/downloadcenter.php?basic=1"
+arch=('x86_64')
+url="https://github.com/3DprintFIT/netfabb-basic-download/releases"
license=('custom:freeware')
depends=('gtk2' 'desktop-file-utils' 'hicolor-icon-theme')
install='netfabb-basic.install'
+sha256sums=('1c1254997b418dd588de6ea3105981e0b86001dea29f322502b2df5ffb3feaa5') # 64-bit
+nARCH=64
-md5sums=('8901e9ed2f93d64a298aa328d762b3d1') # 32-bit
-nARCH=32
-if [ "$CARCH" == x86_64 ] ; then
- md5sums=('19eeb80c953e9eb0e22a635678a1a18e') # 64-bit
- depends[0]="lib32-gtk2"
- nARCH=64
-fi
-if [ -z "$pikey" ] && [ ! -e "netfabb-basic_${pkgver}_linux${nARCH}.tar.gz" ] ; then
- msg "Fetching pikey"
- pikey=$(curl --data "operatinsystems=linux" --data "zusatz=-$pkgver-9" --data "disti=targz" --data "download${nARCH}=Download%20for%20PC%20${nARCH}-Bit" "http://www.netfabb.com/downloadcenter.php?basic=1" | grep pikey)
- pikey="${pikey#*pikey=}"
- export pikey="${pikey%%\">*}"
- [ -z "$pikey" ] && error "Fetching pikey has failed" && exit 1
- msg2 "pikey: $pikey"
-fi
-source=("netfabb-basic_${pkgver}_linux${nARCH}.tar.gz::http://www.netfabb.com/download.php?pikey=${pikey}")
+source=("netfabb-free_${pkgver}_linux${nARCH}.tar.gz::${url}/download/v${pkgver}/")
# Static content
source+=("icons.tar.gz" "netfabb-basic.desktop")
-md5sums+=('a6d3336b9dc60f30f94c9415d578dd7a' '2ab8714cd64e4aaa49457b5bb553f420')
+sha256sums+=( 'ae44b987b08bfaf2a16e250693bef705beddb3fc8612204220efba86fa4fa8ca' 'bf3891906b73724200839a651c74d53b175f810d52779ba925988c1d5236be9f')
package () {
cd "$srcdir"
-# install -d "$pkgdir/usr/share/licenses/$pkgname"
-# cp "$pkgdir/usr/share/doc/$pkgname/copyright" "$pkgdir/usr/share/licenses/$pkgname/"
install -d "$pkgdir/usr/bin/"
- install -m 755 ./netfabb_free "$pkgdir/usr/bin/netfabb-basic"
+ install -m 755 ./netfabb-free_${pkgver}_linux${nARCH}/netfabb_free "$pkgdir/usr/bin/netfabb-basic"
install -d "$pkgdir/usr/lib/"
- install -m 755 ./*.so.* "$pkgdir/usr/lib/"
+ install -m 755 ./netfabb-free_${pkgver}_linux${nARCH}/*.so.* "$pkgdir/usr/lib/"
install -d "$pkgdir/usr/share/applications"
install -m 644 ./*.desktop "$pkgdir/usr/share/applications/"