summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXyne2015-06-21 02:45:17 +0000
committerXyne2015-06-21 02:45:17 +0000
commitfe1539eccddd6a6ea405b02223b109c9e9f4c66f (patch)
tree24eb0268cb00bf4ea8bc14d4572fca9779473bff /PKGBUILD
downloadaur-networkmod.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e77690927b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 100111 2010-11-20 11:25:37Z pierre $
+# Maintainer: Thomas Bächler <thomas@archlinux.org>
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=networkmod
+pkgver=2010.07
+pkgrel=1
+pkgdesc="Modified version of the Arch initscript's Network daemon, with hooks."
+arch=('i686' 'x86_64')
+url="http://xyne.archlinux.ca/scripts/arch/"
+license=('GPL')
+depends=('initscripts')
+optdepends=('bridge-utils: Network bridging support'
+ 'dhcpcd: DHCP network configuration'
+ 'wireless_tools: Wireless networking')
+source=("ftp://ftp.archlinux.org/other/initscripts/initscripts-${pkgver}-1.tar.xz"
+ 'hooks.patch')
+md5sums=('0cea15a64d999d0e1aa0c4bb4dbd1af8'
+ '5006fd23407dea751fdbd23625607ede')
+
+package() {
+ cd "${srcdir}/initscripts-${pkgver}-1"
+ patch network "$srcdir/hooks.patch"
+ install -Dm755 network "$pkgdir/etc/rc.d/networkmod"
+}