summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxwell Pray2018-02-05 22:19:24 -0800
committerMaxwell Pray2018-02-05 22:19:24 -0800
commitee3e9b5088ed069231a3df0431c744bfba4c8aa8 (patch)
treec35161611b9a124d7b0859c786aa2e697caaa46b /PKGBUILD
downloadaur-nextcloud-theme-breeze-dark-git.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef0a8552a8aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname=nextcloud-theme-breeze-dark-git
+pkgver=20171112.0d844ac
+pkgrel=1
+pkgdesc="A Breeze Dark Theme for Nextcloud based on the Breeze Dark theme made by the KDE Project."
+arch=(any)
+url="https://github.com/mwalbeck/nextcloud-breeze-dark"
+license=(AGPL3)
+makedepends=(git)
+source=(git+https://github.com/mwalbeck/nextcloud-breeze-dark.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/nextcloud-breeze-dark"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/webapps/nextcloud/themes"
+ cp -r "$srcdir/nextcloud-breeze-dark" "$pkgdir/usr/share/webapps/nextcloud/themes"
+}