summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Hüsers2022-12-06 22:00:00 +0100
committerManuel Hüsers2022-12-06 22:00:00 +0100
commit9775f90b128af9628641bfb4ee162689658c94f3 (patch)
tree18a91e41cfae47b8bebd9e19e5edf91952dfaf90 /PKGBUILD
parentdb5f4adedffd7a365aa69fc94dc97beabc0ffbd7 (diff)
downloadaur-nginx-mod-traffic-accounting.tar.gz
upgpkg: nginx-mod-traffic-accounting 2.0+18+g46aae3e-1
Added patch that adds option for collecting only successful requests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 821b6c5bf15d..4fc36ee6d371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Manuel Hüsers <aur@huesers.de>
pkgname=nginx-mod-traffic-accounting
-pkgver=2.0+16+g98af5fc
+pkgver=2.0+18+g46aae3e
pkgrel=1
_modname="traffic-accounting-nginx-module"
@@ -14,15 +14,15 @@ url="https://github.com/Lax/${_modname}"
license=('BSD')
source=(
- "https://github.com/Lax/${_modname}/archive/v${pkgver%%+*}/${_modname}-v${pkgver%%+*}.tar.gz"
+ "https://github.com/Lax/${_modname}/archive/v${pkgver%%+*}/${_modname}-${pkgver%%+*}.tar.gz"
"d53a4a6.patch"
"server_addr.patch"
+ "succ_collect.patch"
)
-sha256sums=(
- '8c99c5313e5c822aa5683691c8a0641499b2fa8c67f9e55652817042e21f5986'
- '9bad093fba01d67098d98122202693ffba20feb20668f73e7712d9d9b9915bf1'
- 'e25f170801179e067c7186f1e27fcb3f4273ac5683f6a4962dee821d5eddc8d0'
-)
+sha256sums=('8c99c5313e5c822aa5683691c8a0641499b2fa8c67f9e55652817042e21f5986'
+ '9bad093fba01d67098d98122202693ffba20feb20668f73e7712d9d9b9915bf1'
+ 'e25f170801179e067c7186f1e27fcb3f4273ac5683f6a4962dee821d5eddc8d0'
+ 'e9075be4a309948eaddaed2ceb038dcbf1d3aed92fcfe6c068e415ef6461696d')
prepare() {
mkdir -p build
@@ -33,6 +33,7 @@ prepare() {
cd "../${_modname}-${pkgver%%+*}"
patch -Np1 -i '../d53a4a6.patch'
patch -Np1 -i '../server_addr.patch'
+ patch -Np1 -i '../succ_collect.patch'
}
build() {