aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndreas2023-11-14 12:26:24 +0100
committerAndreas2023-11-14 12:26:24 +0100
commit98a5de707a4f3f49459211e5d903ae597ea7fbe5 (patch)
treeaeec1ecf36a4a15791ddcbe1a4d9dfb3c2d5a316 /PKGBUILD
downloadaur-nicelock.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e2abfd428f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=nicelock
+pkgver=1.0
+pkgrel=1
+pkgdesc="Nice looking lock screen based on i3lock"
+arch=("any")
+url="https://github.com/Kruhlmann/nicelock"
+license=("GPL")
+depends=("imagemagick" "xorg-xrandr" "i3lock" "coreutils" "grep")
+optdepends=("libnotify: for desktop notifications" "dunst: for controlling dunst notifications")
+source=("nicelock")
+sha256sums=("00fac3ed209599ac1f74317a5f6261450c384be6423b35ac246945e45edf7c6c")
+
+package() {
+ install -Dm755 "${srcdir}/nicelock" "${pkgdir}/usr/bin/nicelock"
+}