summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-01-18 02:12:23 +0800
committerChocobo12023-01-18 02:12:23 +0800
commit3076fba5326cf5a651ffaf15e31b1b24663a4821 (patch)
tree2ac1748e07661496cb1fcf3816911bee54c1ecfe /PKGBUILD
parent4f5f23e44cdfcec21fe73de9fd53d34efaec080b (diff)
downloadaur-nlnetlabs-krill-git.tar.gz
upgpkg: nlnetlabs-krill-git 0.12.1.r0.g6374cb80-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 496832bda062..b25c2492215d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=nlnetlabs-krill-git
-pkgver=0.10.0.r0.g2c00aa05
+pkgver=0.12.1.r0.g6374cb80
pkgrel=1
pkgdesc="RPKI certificate authority and publication server"
arch=('i686' 'x86_64')
@@ -15,6 +15,15 @@ source=("git+https://github.com/NLnetLabs/krill.git")
sha256sums=('SKIP')
+prepare() {
+ cd "krill"
+
+ if [ ! -f "Cargo.lock" ]; then
+ cargo update
+ fi
+ cargo fetch
+}
+
pkgver() {
cd "krill"
@@ -25,16 +34,15 @@ check() {
cd "krill"
#cargo test \
- # --locked \
- # --release
+ # --frozen
}
package() {
cd "krill"
cargo install \
- --no-track \
--locked \
+ --no-track \
--root "$pkgdir/usr" \
- --path "$srcdir/krill"
+ --path .
}