summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Kuc2020-06-25 09:14:02 +0100
committerMichael Kuc2020-06-25 09:14:02 +0100
commitb4876c9d134fd2f5b346ef0a18e981dae1709837 (patch)
tree7cd00e914f3fb81d3183528164291eaf52008370 /PKGBUILD
parent8bda12d8a7a8eb76a412f3cddf80ace27de097dd (diff)
downloadaur-nngpp-git.tar.gz
fix: update build to only compile in test section
By only compiling the header-only library in the test section, people can simply avoid test failures by using the `--nocheck` argument to `makepkg`.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8f0259fb35a..65860f125279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=nngpp
pkgname=${_pkgname}-git
pkgver=1.3.00cc5d264
-pkgrel=1
+pkgrel=2
pkgdesc="C++ wrapper around the nanomsg NNG API "
arch=('x86_64')
url="https://github.com/cwzx/nngpp"
@@ -20,13 +20,7 @@ pkgver() {
git describe --long --tags | tr -d 'nng\-v' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "${_pkgname}"
- make
-}
-
check() {
- # cd "${_pkgname}/build"
cd "${_pkgname}"
make test
}