summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDian Fay2019-06-06 23:45:19 -0400
committerDian Fay2019-06-06 23:45:36 -0400
commit5aeff385aa20d5a9a20940497123182aaa1332ee (patch)
tree6cae457fe62dbdff6f8071dbc9a4dd9172938a75 /PKGBUILD
downloadaur-nodejs-entropic.tar.gz
download and install ds-latest from entropic.dev
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65779a994220
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dian Fay <dian.m.fay@gmail.com>
+pkgname=nodejs-entropic
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="The Entropic package registry's ds command-line interface"
+arch=("x86_64")
+url="https://entropic.dev"
+license=("MIT")
+install=$pkgname.install
+source=(
+ https://www.entropic.dev/ds-latest.tgz
+)
+makedepends=(
+ "npm"
+)
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/ds-latest.tgz
+}
+md5sums=('cb96ef64adcafe8b93e912028eb2fc1c')