summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago Almeida2019-01-18 11:08:41 -0200
committerThiago Almeida2019-01-18 11:08:41 -0200
commit41562781ecd3574c7c642a10fe70dd2a7d5e5d9a (patch)
tree05e9700f659164e43deb980dc7976ee76f46ab52 /PKGBUILD
downloadaur-nodejs-gitlab-ci-variables-cli.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab9715c31da8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thiago Almeida <thiagoalmeidasa@gmail.com>
+_npmname=gitlab-ci-variables-cli
+_npmver=3.0.0
+pkgname=nodejs-gitlab-ci-variables-cli # All lowercase
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="CLI tool to set/get pipeline variables on Gitlab CI."
+arch=(any)
+url="https://github.com/temando/gitlab-ci-variables-cli#readme"
+license=(MIT)
+depends=('nodejs' 'npm')
+optdepends=()
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(2ab853389e3fb184c2ac253c12b95e26c50c8db4)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: