summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-06-14 17:08:28 +0200
committerGoliathLabs2020-06-14 17:08:28 +0200
commite117814f88fe5462dcdfab9c4c41bd90e3940acf (patch)
tree3d4dcc6adb66cdf0e8ee1e3154ae236d9ba9900b /PKGBUILD
parent24c0a83b3882896167edb9ea4c4bd2c27553cd9c (diff)
downloadaur-nodejs-markserv.tar.gz
Updated: 1.17.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 24 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bee8e7d7633d..c8f23dd37ce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+
+
_npmname=markserv
pkgname=nodejs-$_npmname
-pkgver=0.3.3
+pkgver=1.17.4
pkgrel=1
pkgdesc="Markserv serves Markdown files as GitHub style HTML and LiveReloads your files in the browser as you edit."
arch=(any)
@@ -8,10 +11,27 @@ url="https://github.com/f1lt3r/markserv"
license=('MIT')
depends=('npm')
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+
noextract=($_npmname-$pkgver.tgz)
-sha256sums=('e1d92987f6340372308443831a58811163b548bd9ca5fa40a01627673908546b')
+sha256sums=('7f9564290f461cdf131354f70b9fa9e79e7f1c4b306c0f3273de69d2d946d029')
package() {
- npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
- chmod -R go-w "$pkgdir"/usr
+ npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+
+ # Fix permissions
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+
+ # Remove references to pkgdir
+ find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
+
+ # Remove references to srcdir
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$_npmname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
}