summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Schaf2015-06-11 19:36:00 +0200
committerPhil Schaf2015-06-11 19:36:00 +0200
commit6747b7d229bffa2da4c0680bad1fb5017e4ecc56 (patch)
tree43a2bc23218c79995a23309f2f5715d9f6a94e92 /PKGBUILD
downloadaur-nodejs-nib.tar.gz
aur4 migration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b19f3a789517
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+_npmname=nib
+pkgname="nodejs-$_npmname" # All lowercase
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Stylus mixins, utilities, components, and gradient image generation'
+arch=(any)
+url="https://github.com/visionmedia/$_npmname"
+license=()
+depends=('nodejs-stylus')
+source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+noextract=("$_npmname-$pkgver.tgz")
+sha1sums=('527c19662a10a2b565fe85e9b309d622aa7557d3')
+
+package() {
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+} \ No newline at end of file