summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Vincent2017-05-15 16:37:11 +0100
committerTom Vincent2017-05-15 16:37:11 +0100
commit4e92fc0d73dc2192996d5036dbc8c462056d8e7e (patch)
tree7aaf01977b672550129b5c467873f83d659f5ed8 /PKGBUILD
downloadaur-nodejs-pouchdb-dump-cli.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..668aa560e683
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_npmname=pouchdb-dump-cli
+pkgname=nodejs-$_npmname
+pkgver=2.0.6
+pkgrel=1
+pkgdesc="Command-line tool for dumping a CouchDB/PouchDB database to a file"
+arch=(any)
+url="https://github.com/nolanlawson/pouchdb-dump-cli"
+license=('Apache')
+depends=('npm')
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('69e9e74623d4357f8a932d0b5f79efd029df25a7915114479a8e300996db6186')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ chmod -R go-w "$pkgdir"/usr
+}