summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun2020-12-11 22:07:23 +0800
committeryjun2020-12-11 22:07:23 +0800
commita6060f8f9016d793b0d4147c6aabcbdfc0771dea (patch)
tree85b70f83a7a0a195a76d2d65659abe9bcba9010d /PKGBUILD
parent34092e377c5d081f7526391c1a54078b9c9dfe4a (diff)
downloadaur-nodemcu-uploader-git.tar.gz
added provides and conflicts && updated the package description
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dd21ecc5bbc..2e4e6d46c0ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,36 @@
pkgname=nodemcu-uploader-git
_gitname=nodemcu-uploader
-pkgver=v0.4.3.r35.g3e07591
-pkgrel=2
-pkgdesc="Upload files to your esp8266 running nodeMcu"
+pkgver=v1.0.0.r0.g6893b41
+pkgrel=1
+pkgdesc="tool for uploading files to the filesystem of an ESP8266 running NodeMCU."
arch=("any")
url="https://github.com/kmpm/nodemcu-uploader"
license=('MIT')
depends=('python-pyserial')
makedepends=('git')
-source=("git+https://github.com/kmpm/nodemcu-uploader.git")
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=("git+https://github.com/kmpm/nodemcu-uploader")
sha256sums=('SKIP')
+
pkgver() {
cd $_gitname
+
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd $_gitname
+
python setup.py build
}
+
package() {
cd $_gitname
+
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
+
+# vim:set sw=2 ts=2 et: