summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZack Ashen2020-06-15 16:37:57 -0400
committerZack Ashen2020-06-15 16:37:57 -0400
commit473f48fd44423d776f99a6ede43f85631e55a621 (patch)
treea83e24fa2e54f76af4e6212b38de756378b03929 /PKGBUILD
downloadaur-noted-cli-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28fa4be03846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Zachary Ashen <zachary.h.a@gmail.com>
+pkgname=noted-cli-git
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Noted is a cli note taking and todo app similar to google keep or any other note taking service. It is a fork of my previous project keep-cli. Notes appear as cards. You can make lists and write random ideas."
+arch=(x86_64 i686)
+url="https://github.com/zack-ashen/noted"
+license=('MIT')
+depends=(python)
+makedepends=(python-setuptools git)
+provides=(noted-cli-git)
+conflicts=(noted-cli-git)
+source=(git+$url)
+md5sums=('SKIP')
+
+_pkgname=noted
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "0.1.4.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ msg "Running setup.py"
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+}