summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2024-03-11 16:04:17 +0800
committertaotieren2024-03-11 16:04:17 +0800
commit134fb33a6b463fd51927370a8e9d5864ca746cb3 (patch)
tree52c5315079fb07a1f358e5d224cab905e512eb43 /PKGBUILD
parente11cdf427d330255354192ee80a3d591198be53b (diff)
downloadaur-notepad---git.tar.gz
[lilac] updated to 2.14.r1.g335b72c-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5056be1e99f..9228d381f296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=notepad---git
-pkgver=2.12.r5.ga89e9c6
-pkgrel=3
+pkgver=2.14.r1.g335b72c
+pkgrel=1
pkgdesc="Notepad-- 是使用C++编写的轻量级文本编辑器, 简称ndd, 可以支持Window/Mac/Linux操作系统平台。"
arch=('x86_64')
url="https://gitee.com/cxasm/notepad--"
@@ -10,13 +10,17 @@ license=('GPL-3.0-or-later')
provides=(${pkgname%-git} notepadplugin)
conflicts=(${pkgname%-git})
_qt=qt5
-depends=($_qt-base
- $_qt-xmlpatterns
- qscintilla-$_qt)
+depends=(
+ glibc
+ gcc-libs
+ hicolor-icon-theme
+ $_qt-base)
makedepends=(cmake
ninja
git
- $_qt-tools)
+ $_qt-tools
+ $_qt-xmlpatterns
+ qscintilla-$_qt)
source=("${pkgname}::git+${url}.git")
sha256sums=('SKIP')
@@ -40,7 +44,7 @@ build() {
sed -i '7s/NotePad--/notepad--/' src/linux/usr/share/applications/NotePad--.desktop
- cmake -D CMAKE_BUILD_TYPE=None \
+ cmake -D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \
-B build \
-G Ninja \