summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeg2016-07-31 22:04:03 +0300
committerNeg2016-07-31 22:04:03 +0300
commit1a31af0fc1ab8aec3b477f19bb362a8af7e2563d (patch)
treee7189128d8523fae418d23dfe77f5a6f38b95ce3 /PKGBUILD
downloadaur-notion-neg-git.tar.gz
add pkgbuild for my notion wm fork
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a4aac5ab5ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sergey Miroshnichenko <serg.zorg@gmail.com>
+
+pkgname=notion-neg-git
+pkgver=3612
+pkgrel=1
+pkgdesc="NotionWM fork with compton, dzen2, rofi, xft fonts support different default cfg"
+url="https://github.com/neg-serg/notion"
+arch=('i686' 'x86_64')
+license=('custom:LGPL')
+depends=('glib2' 'gettext' 'lua' 'libxext' 'libsm')
+optdepends=('libxrandr: xrandr support'
+ 'compton: X11 compositing support')
+makedepends=('git' 'libxrandr' 'rofi' 'dzen2-xft-xpm-xinerama-git')
+provides=('libtu' 'libextl' 'notion')
+conflicts=('notion')
+
+source=("notion::git://github.com/neg-serg/notion")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/notion"
+ git rev-list --count HEAD
+}
+
+build() {
+ cd "${srcdir}/notion"
+ make
+}
+
+package() {
+ cd "${srcdir}/notion"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/notion/LICENSE"
+ mkdir -p "${pkgdir}/usr/share/xsessions"
+ cat > "${pkgdir}/usr/share/xsessions/notion.desktop" <<EOF
+[Desktop Entry]
+Name=Notion
+Comment=This session logs you into Notion
+Exec=notion
+TryExec=notion
+Icon=
+Type=XSession
+EOF
+ for i in "${srcdir}/notion/example_cfg/"*; do
+ cp -rv "${i}" "${pkgdir}/usr/etc/notion"
+ done
+}