summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2025-01-12 15:34:22 +0800
committertaotieren2025-01-12 15:34:22 +0800
commitdc43444ea556d4426274ed124ca12cf8b0e5a4fc (patch)
tree4c2460607494eed0027e728003c61cbcc7a2abc4 /PKGBUILD
parent98d0b26bd7f85d95e8da2f94e550b218f82d5b8a (diff)
downloadaur-nrf-command-line-tools-bin.tar.gz
[lilac] updated to 10.24.2-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 025e17de937e..6ec356b18e33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=nrf-command-line-tools-bin
pkgname=(nrf-command-line-tools python-nrf-command-line-tools)
_pkgname=${pkgbase%-bin}
pkgver=10.24.2
-pkgrel=0
+pkgrel=5
arch=('x86_64' 'aarch64')
makedepends=(python-wheel
python-setuptools-scm
@@ -24,7 +24,7 @@ sha256sums_aarch64=('568d1b7bac35fbcaa0320ef50dfc4fa94d672441636284ab532a05d74bc
optdepends=("nrf-udev: udev rules for nRF (Nordic Semiconductor) development kits"
"pc-nrfconnect-programmer: Programmer app for nRF Connect for Desktop")
-build () {
+build() {
cd "${srcdir}"/${_pkgname}/python
python -m build --wheel --no-isolation
}
@@ -48,9 +48,8 @@ package_python-nrf-command-line-tools() {
pkgdesc+=" (Python)"
depends=(jlink-software-and-documentation
- python
- python-future
- python-tomli-w)
+ python
+ python-tomli-w)
provides=(python-pynrfjprog)
conflicts=(python-pynrfjprog)