summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Eisvogel2017-05-29 16:41:43 +0200
committerStephan Eisvogel2017-05-29 16:41:43 +0200
commit97a695aea90a261043b9fe068499c463cb125f55 (patch)
tree4835e9b35ffe911e8613915897f4e2f590150e13 /PKGBUILD
parentc0e08827dd3bb7c69d2b0e20bf074f8febe898a4 (diff)
downloadaur-97a695aea90a261043b9fe068499c463cb125f55.tar.gz
Build process fixes, delete doxygen/graphviz make dependancy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee555a72cfd7..cc6b5cedf1e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Stephan Eisvogel <eisvogel at embinet dot de>
pkgname=nsjail-git
-pkgver=r450.3e99703
-_pkgcommit=#commit=3e99703df21978f4f87717e1563fbbc9454c6848
+pkgver=r457.cae0c4a
pkgrel=1
+_pkgcommit=#commit=cae0c4a7f5420b7bf0fb0046a8c13fedfe9d0a44
pkgdesc="A light-weight process isolation tool, making use of Linux namespaces and seccomp-bpf syscall filters (with help of the kafel bpf language)"
arch=('x86_64')
url="http://nsjail.com"
license=('Apache')
-makedepends=('git' 'autoconf-archive>2016.03.20' 'doxygen' 'graphviz' 're2c' 'check>=0.9.4')
+makedepends=('git' 'autoconf-archive>2016.03.20' 're2c' 'check>=0.9.4')
depends=('libnl>=3' 'protobuf-c')
source=("${pkgname}::git+git://github.com/google/nsjail.git${_pkgcommit}"
"https://github.com/trustm3/external_protobuf-c-text/commit/c37f8708d847319921a3fba7d6863103f6b801e2.patch"
@@ -39,6 +39,8 @@ prepare() {
sed -i '/^include am\/aminclude_doxygen.am/c@DX_RULES@' protobuf-c-text/Makefile.am
# Fix wrong variable usage
sed -i 's/\$(GREP) \/libdata\//\$GREP \/libdata\//' protobuf-c-text/configure.ac
+ # Fix bison warning
+ sed -i '/if (!ctxt->lexical_error) {/aYYUSE(scanner);' kafel/src/parser.y
# 3rd party fixes
@@ -58,7 +60,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}/protobuf-c-text"
autoreconf -vif
- env CFLAGS="${CFLAGS} -fPIC" ./configure
+ env CFLAGS="${CFLAGS} -fPIC" ./configure --enable-shared=no --disable-doxygen-doc
cd "${srcdir}/${pkgname}"
make
}