summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2019-05-29 20:44:04 -0400
committerGI_Jack2019-05-29 20:44:04 -0400
commitf3ad85c1ead17073cf0f092846f6112e5b13b219 (patch)
treec966b904abac89861c0e7ac649e8e73818283cf8 /PKGBUILD
parent799e5b4d1e4d422adf0d9aeac8bc6d74fb442f15 (diff)
downloadaur-ntdsxtract.tar.gz
updated
* changed md5sum to sha256sum * updated source to archive.org
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47b5e12ddd46..120c946ab6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Original: Steven Honeyman <stevenhoneyman at gmail com>
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
pkgname=ntdsxtract
pkgver=1.3.1
@@ -8,19 +9,19 @@ arch=('i686' 'x86_64')
url="http://www.ntdsxtract.com/"
license=('GPL2')
depends=('python2' 'python2-crypto' 'libesedb')
-source=($pkgname-$pkgver.zip::http://www.ntdsxtract.com/downloads/ntdsxtract/ntdsxtract_v1_3_1_beta.zip)
-md5sums=('0057e137ced55a2e16b9c5d681f6f8ee')
+source=($pkgname-$pkgver.zip::https://web.archive.org/web/20161024031803/http://www.ntdsxtract.com/downloads/ntdsxtract/ntdsxtract_v1_3_1_beta.zip)
+sha256sums=('3216f7eac63be77c205c39ab695a9370e1a53c8df88618a8bbf18babe6831e7e')
prepare() {
- cd "$srcdir"
- sed -i '1s/^/#!\/usr\/bin\/python2\n/' *.py
+ cd "$srcdir"
+ sed -i '1s/^/#!\/usr\/bin\/python2\n/' *.py
}
package() {
- cd "$srcdir"
- mkdir -p "$pkgdir"/usr/lib/python2.7/site-packages
- cp -ar {ntds,framework} "$pkgdir"/usr/lib/python2.7/site-packages
- for f in *.py; do
- install -Dm755 "$f" "$pkgdir"/usr/bin/${f%.py}
- done
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/lib/python2.7/site-packages
+ cp -ar {ntds,framework} "$pkgdir"/usr/lib/python2.7/site-packages
+ for f in *.py; do
+ install -Dm755 "$f" "$pkgdir"/usr/bin/${f%.py}
+ done
}