summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 13:23:59 +0200
committerChristian Hesse2015-06-29 13:23:59 +0200
commit4160828ebaef987d31970935e1a9140a8a68ecec (patch)
tree504ac536953d6e50c4a27f102f5d03324acf94f1 /PKGBUILD
downloadaur-ntfsfixboot.tar.gz
initial import of ntfsfixboot 1.0-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f503bb07cae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=ntfsfixboot
+pkgver=1.0
+pkgrel=4
+pkgdesc="Fix NTFS boot sector"
+arch=('i686' 'x86_64')
+url='http://sourceforge.net/projects/ntfsfixboot/'
+license=('GPL')
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('88776b669ea77f1d9ab30ae38d4480c0f929768bb3901b2e47cc9b3618b4b6cb')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}/
+
+ # make sure it cross compiles
+ sed '/gcc -Wall -o $(TARGET) \$</ s/$/ $(CFLAGS)/' -i Makefile
+ make
+}
+
+package() {
+ install -D -m 0755 ${srcdir}/${pkgname}-${pkgver}/ntfsfixboot ${pkgdir}/usr/bin/ntfsfixboot
+}
+