diff options
author | Jonathon Fernyhough | 2020-08-18 13:31:01 +0100 |
---|---|---|
committer | Jonathon Fernyhough | 2020-08-18 13:31:01 +0100 |
commit | d480b3f1e9028121c5a8c5018323aae8451e1e66 (patch) | |
tree | 76aae85f214bdc4a2a509fed97832bb7db847f80 /PKGBUILD | |
parent | 2bcfc3e866335cc847055eaba234df3c4c2e7481 (diff) | |
download | aur-numix-gtk-theme-git.tar.gz |
Update for sassc, tweak PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 30 |
1 files changed, 17 insertions, 13 deletions
@@ -1,34 +1,38 @@ +# Maintainer: Jonathon Fernyhough <jonathon+m2x.dev> +# Previous Maintainer : Erik Dubois <erik.dubois@gmail.com> # Previous Maintainer: Maxime Gauduin <alucryd@archlinux.org> # Contributor: Diego <cdprincipe@gmail.com> -# Maintainer : Erik Dubois <erik.dubois@gmail.com> pkgname=numix-gtk-theme-git -pkgver=2.6.7.r51.b652b19 +pkgver=2.6.7.r52.15923f7 pkgrel=1 pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)' arch=('any') url='https://github.com/numixproject/numix-gtk-theme' license=('GPL3') -makedepends=('gdk-pixbuf2' 'git' 'glib2' 'libxml2' 'ruby-sass') +makedepends=('gdk-pixbuf2' 'git' 'glib2' 'sassc') optdepends=('gtk-engine-murrine: GTK2 theme engine') -provides=('numix-gtk-theme-git') conflicts=('numix-gtk-theme') -replaces=('numix-gtk-theme') -source=('git+https://github.com/numixproject/numix-gtk-theme.git') -md5sums=('SKIP') +provides=('numix-gtk-theme') +source=("git+$url.git") +b2sums=('SKIP') + +prepare() { + # `make install` triggers that `all` target, don't need to do that twice + sed -i '41s@ all@@' numix-gtk-theme/Makefile +} pkgver() { - cd numix-gtk-theme #git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./' - git describe --tags | sed 's/2.6.6/2.6.7/; s/-/.r/; s/-g/./' + + # 2.6.7 not tagged in master, https://github.com/numixproject/numix-gtk-theme/issues/747 + git -C numix-gtk-theme describe --tags | sed 's/2.6.6/2.6.7/; s/-/.r/; s/-g/./' } build() { - cd numix-gtk-theme - make + make -C numix-gtk-theme } package() { - cd numix-gtk-theme - make DESTDIR="${pkgdir}" install + make -C numix-gtk-theme DESTDIR="$pkgdir" install } |