summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJameson Pugh2016-03-30 11:09:15 -0400
committerJameson Pugh2016-03-30 11:09:15 -0400
commit0a9bb76e73f8e477e52c56cf7c40bc068fc3dc41 (patch)
treef7f835e1b4a9cf85f6374465c6d9505b420bc3bc /PKGBUILD
downloadaur-nunc-stans.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f1ce1811574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=nunc-stans
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="an event framework wrapper"
+arch=('i686' 'x86_64')
+url="http://directory.fedoraproject.org/"
+license=('GPL')
+depends=('nspr' 'libevent' 'tevent')
+source=("http://directory.fedoraproject.org/sources/$pkgname-$pkgver.tar.bz2")
+sha256sums=('66cee78fce36f3a496b454c6cebf7511089a23825207591338bf10178d84dfb5')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ [ "${CARCH}" == "x86_64" ] && export USE_64=1
+
+ msg2 "Running configure..."
+ ./configure --disable-rpath \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --with-ldapsdk-inc=/usr/include/mozldap \
+ --with-ldapsdk-lib=/usr/lib/mozldap \
+ --with-adminutil=/usr
+
+ msg2 "Running make..."
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ msg2 "Running make install..."
+ make install DESTDIR="${pkgdir}"
+}
+
+# vim:set ts=2 sw=2 et: