summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Mazieres2020-09-20 16:19:56 +0200
committerDavid Mazieres2020-09-20 16:19:56 +0200
commit035bd57aff5e0d3472acb48cf2ee7a898b2eb897 (patch)
treedba23505db2f086a604a744fb255c3f6f4c91386 /PKGBUILD
parent4b5015d6a24ab8599960dc0a81094032f087e351 (diff)
downloadaur-obs-motion-effect-git.tar.gz
don't fail if obs version doesn't correspond to git tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f75629113de2..4aca2d542311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=obs-motion-effect-git
obsver=$(obs --version | sed -e 's/[^0-9]*//;s/\(-\|\.[^0-9]\).*//' 2>/dev/null)
pkgver=1.2.1.r3.167596a+obs25.0.8
-pkgrel=1
+pkgrel=2
pkgdesc="v4l2-output for obs-studio"
arch=(x86_64)
url="https://github.com/CatxFish/motion-effect"
@@ -34,7 +34,7 @@ pkgver() {
prepare() {
cd "$srcdir"
# If obs is installed, then try to match installed version
- test -z "$obsver" || git -C obs-studio checkout "$obsver"
+ test -z "$obsver" || git -C obs-studio checkout "$obsver" || :
mkdir -p build
cd build
cmake -DLIBOBS_INCLUDE_DIR="../obs-studio/libobs" -DCMAKE_INSTALL_PREFIX=/usr "../${pkgstem}"