summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-10-10 12:01:02 +0200
committerJ5lx2015-10-10 12:01:02 +0200
commitc35bf45fe0784c0583f02df9905de8d315760dfe (patch)
tree3f9d81563b9b5cf9ec3f3182ac695e84438c1aa3 /PKGBUILD
downloadaur-ocaml-includepatch.tar.gz
1.0-2: Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de578be885ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Leonard de Ruijter <leonard@aur.archlinux.org>
+
+pkgname=ocaml-includepatch
+pkgver=1.0
+pkgrel=2
+license=('custom')
+arch=('any')
+pkgdesc="OCAML saves its includefiles in /usr/lib/ocaml/caml. Due to the unusual location for these files which makes compiling certain libraries impossible, this package symlinks this path to /usr/include/caml"
+url="http://caml.inria.fr/ocaml/"
+depends=('ocaml')
+
+package() {
+ install -d "${pkgdir}/usr/include"
+ ln -s "/usr/lib/ocaml/caml" "${pkgdir}/usr/include/caml"
+}