summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:43:27 +0200
committerDaniel Peukert2022-06-14 20:43:27 +0200
commit3772b44927da50493f6f7de8851d4b6429fe342f (patch)
tree8716c43edd23729260174a2b93bfc7e801760383 /PKGBUILD
parentdeff7b0a55b041e0306757002c28454f2e206c8b (diff)
downloadaur-ocaml-ppx_tools.tar.gz
Fix dun calls, sha256 -> sha512
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d388c9437f5..7b26398116be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ppx_tools'
pkgname="ocaml-$_projectname"
pkgver='6.5'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Tools for authors of ppx rewriters and other syntactic tools'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
@@ -23,11 +23,7 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"