summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Bailey2018-01-25 17:34:25 -0500
committerEric Bailey2018-01-25 17:34:25 -0500
commit1b6308f9062cfa53dcbc6ae00b2d7aba8a70c6fb (patch)
tree108c492e221e633c70f7958d5db200ae06c270dc /PKGBUILD
parentc834e344e90073cce9535e9d933df6f1d71ebc1d (diff)
downloadaur-1b6308f9062cfa53dcbc6ae00b2d7aba8a70c6fb.tar.gz
update to 1.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10c6a293a4e4..45c9b59313aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=ocaml-yojson
_oname=yojson
-pkgver=1.3.3
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc='An optimized parsing and printing library for JSON'
arch=('i686' 'x86_64' 'armv7h')
options=('!makeflags' '!strip' 'staticlibs')
@@ -12,16 +12,15 @@ depends=('ocaml-biniou' 'ocaml-easy-format')
makedepends=('ocaml-findlib' 'ocamlbuild' 'cppo')
url="https://github.com/mjambon/yojson"
source=("https://github.com/mjambon/${_oname}/archive/v${pkgver}.tar.gz")
-sha256sums=('de5ad4fd681f58ae5a670f0a43684873cc6ca50bdf52e63ac0c4b8a8bbe1d51a')
+sha256sums=('7d06340b769ed6ff5b2171a0e820d1e8f4337aef3929090fc976efe845639146')
build() {
- cd $srcdir/$_oname-$pkgver
- make && make doc
+ cd ${srcdir}/${_oname}-${pkgver}
+ make all
}
package() {
- cd $srcdir/$_oname-$pkgver
- mkdir -p $pkgdir/usr/bin $pkgdir$(ocamlfind printconf destdir)
- make OCAMLFIND_DESTDIR=${pkgdir}$(ocamlfind printconf destdir) install BINDIR="${pkgdir}/usr/bin"
- install -dm755 "${pkgdir}/usr/share/doc/$pkgname"
- install -t "${pkgdir}/usr/share/doc/$pkgname" doc/*
+ cd ${srcdir}/${_oname}-${pkgver}
+ export OCAMLFIND_DESTDIR="${pkgdir}/$(ocamlfind printconf destdir)"
+ install -dm755 "$OCAMLFIND_DESTDIR"
+ jbuilder install
}