summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcondy2022-06-17 20:51:07 +0800
committercondy2022-06-17 20:51:07 +0800
commit3f6f3ed93a8ada829c662bfcdbc4b94194c89741 (patch)
tree677836d81a2306ce581ecbce5b2d15e4a1ed6d0b /PKGBUILD
parent83d2c77494d9d070f5ce88fc45433f50f5cb8761 (diff)
downloadaur-3f6f3ed93a8ada829c662bfcdbc4b94194c89741.tar.gz
Revert "Update to 2.0.0"
This reverts commit 83d2c77494d9d070f5ce88fc45433f50f5cb8761. For building merlin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f160ded8ae68..e539cb6a82de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=yojson
pkgname=ocaml-${_pkgname}
-pkgver=2.0.0
-pkgrel=1
+pkgver=1.7.0
+pkgrel=3
pkgdesc="Low level JSON binary for OCaml"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
@@ -12,28 +12,20 @@ license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-yojson')
conflicts=('ocaml-yojson')
-depends=()
+depends=('ocaml-biniou' 'ocaml-easy-format')
makedepends=('dune' 'cppo')
source=(https://github.com/ocaml-community/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz)
-sha256sums=('ab5d863f7f951a8f7fb4a708399ca2da2cf139a5e0af7818145c20295420cb1a')
+sha256sums=('656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6')
build() {
cd ${_pkgname}-${pkgver}
-
- # Since we're using ocaml latest, at least 4.13.1
- sed -i '/(libraries seq)/d' lib/dune
-
- # No need to build the benchmarks
- rm yojson-bench.opam
- rm -r bench/
-
make all
}
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="/usr/lib/ocaml"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="lib/ocaml"
# remove rogue dune-package file
rm -r "${pkgdir}"/usr/doc