summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcondy2020-02-07 19:37:59 +0800
committercondy2020-02-07 19:37:59 +0800
commite7ff5db1585b4d7df6209e4c89cf7f376d4f341c (patch)
tree190fadb52267ee819503a3da7dd74b2ef9f7fd36 /PKGBUILD
parentbfb03a0d7741ab3510d62911f18cfaea816a83a0 (diff)
downloadaur-e7ff5db1585b4d7df6209e4c89cf7f376d4f341c.tar.gz
Update to 1.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cbc997c2da9..958d2afeab6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,33 @@
# Author: Bruno Pagani <archange@archlinux.org>
-# Maintainer: nerflad <nerflad@gmail.com)
+# Maintainer: Zhiwei Chen <condy0919@gmail.com)
_pkgname=yojson
pkgname=ocaml-${_pkgname}
-pkgver=1.4.1
-pkgrel=7
+pkgver=1.7.0
+pkgrel=1
pkgdesc="Low level JSON binary for OCaml"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
license=('BSD')
options=('!strip' 'staticlibs')
+provides=('ocaml-yojson')
+conflicts=('ocaml-yojson')
depends=('ocaml-biniou' 'ocaml-easy-format')
makedepends=('dune' 'cppo')
-source=(${pkgname}-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz"
- 'https://github.com/ocaml-community/yojson/commit/a8095892a38d2a4e98f963c2627ac8cc484e0bbf.patch')
-sha256sums=('c081a8cb5a03bddbcac4614f468cf5edafe11805277572af4071e362be6611fb' '62aeecc4a880f59fcfaa51ad27826e0ad418adb59b3b125ec4d60fe7f671f1b9')
+source=(https://github.com/ocaml-community/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz)
+sha256sums=('656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6')
-prepare() {
- cd ${_pkgname}-${pkgver}
- # fix jbuild dependencies for cppo generation
- patch -p1 -i "${srcdir}/a8095892a38d2a4e98f963c2627ac8cc484e0bbf.patch"
-}
build() {
cd ${_pkgname}-${pkgver}
make all
}
-check() {
- cd ${_pkgname}-${pkgver}
- make test
-}
-
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="$(ocamlfind printconf destdir)"
- install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="lib/ocaml"
+
+ # remove rogue dune-package file
rm -r "${pkgdir}"/usr/doc
rm -r "${pkgdir}"/usr/lib/ocaml/${_pkgname}/dune-package
}