summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-06-22 00:24:51 -0400
committerPatrick Northon2021-06-22 00:24:51 -0400
commite3f3f4581afb021e8aacdc963a284c9070e091c9 (patch)
treed1dde9c2300939f80cde2589eeca6610fa1eaf6c /PKGBUILD
parent69574eb56a90d5a6843c193728c5f053a52c9ca5 (diff)
downloadaur-ocropy.tar.gz
Fix for python2-imaging.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 005d9a17b394..8f4c9b072c2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=ocropy
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python-based OCR package using recurrent neural networks (formerly ocropus)"
arch=('any')
url="https://github.com/ocropus/ocropy"
license=('APACHE')
depends=('python2-imaging' 'python2-scipy' 'python2-matplotlib' 'python2-pytables'
- 'imagemagick' 'opencv' 'python2-beautifulsoup4')
+ 'imagemagick' 'opencv' 'python2-lxml')
source=("$pkgname-$pkgver.tar.gz::https://github.com/ocropus/ocropy/archive/v${pkgver}.tar.gz"
"https://github.com/zuphilip/ocropy-models/raw/master/en-default.pyrnn.gz")
sha256sums=('8582589e87dd453c736478713c2d740c8e3e4479e519d8f8e8f25288081eff5c'
@@ -18,8 +18,8 @@ prepare() {
cd "$srcdir/$pkgname-$pkgver"
cp "$srcdir/en-default.pyrnn.gz" models
- sed -i 's|tostring|tobytes|' ocrolib/common.py
- sed -i 's|PIL\.Image\.fromstring|PIL\.Image\.frombytes|' ocrolib/common.py
+ sed -i 's|tobytes|tostring|' ocrolib/common.py
+ #sed -i 's|PIL\.Image\.fromstring|PIL\.Image\.frombytes|' ocrolib/common.py
}
build() {