summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarc Rechté2021-03-04 09:35:53 +0100
committerMarc Rechté2021-03-04 09:35:53 +0100
commitb5bc01cf498f551a639c1d6a13fe4ce6131eef09 (patch)
tree9570852e0db7d417dab65643a292c6885eba67f5 /PKGBUILD
downloadaur-odyssey.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3de8786869c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Marc Rechté <mrechte@gmail.com>
+pkgname=odyssey
+pkgver=git
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Advanced multi-threaded PostgreSQL connection pooler and request router"
+url="https://github.com/yandex/odyssey"
+license=('custom:BSD')
+depends=('openssl')
+makedepends=('gcc' 'cmake' 'make' 'postgresql')
+backup=('etc/odyssey/odyssey.conf')
+source=("git+https://github.com/yandex/$pkgname.git"
+ odyssey.conf
+ tmpfile_odyssey.conf)
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+install="$pkgname.install"
+
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ make local_build
+}
+
+package() {
+ install -Dm 0640 odyssey.conf "$pkgdir/etc/odyssey/odyssey.conf"
+ install -Dm 0644 tmpfile_odyssey.conf "$pkgdir/etc/tmpfiles.d/odyssey.conf"
+ cd "$pkgname"
+ install -Dm 0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 0755 "build/sources/odyssey" "$pkgdir/usr/bin/odyssey"
+ install -Dm 0755 scripts/systemd/odyssey.service "$pkgdir/usr/lib/systemd/system/odyssey.service"
+}