summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcrwxrws2019-10-10 02:46:11 +0200
committercrwxrws2019-10-10 02:50:05 +0200
commitb47083c4ebf5a2ef363b67276234653860e18888 (patch)
tree0c745778a1fff730b52ee748cfe5e9bfec8d6d93 /PKGBUILD
downloadaur-ofmc-bin.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbe02362b9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Fridrich Csoltko <crwxrws@protonmail.com>
+
+pkgname=ofmc-bin
+_pkgname=ofmc
+pkgver=2018
+pkgrel=1
+pkgdesc="Open-Source Fixed-Point Model-Checker"
+arch=('x86_64')
+url="http://www.imm.dtu.dk/~samo/"
+license=('BSD')
+depends=('gmp' 'libffi')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("http://www.imm.dtu.dk/~samo/$_pkgname-$pkgver.zip")
+md5sums=('25dbffa5e0f8da90fa6b28d943b09965')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -Dm755 "executable for linux/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "BSD License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}