summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Blankertz2019-11-20 20:53:07 +0100
committerMatthias Blankertz2019-11-20 20:53:07 +0100
commit53736d49b732203b82b9b3b10406765340dcf9d6 (patch)
tree25dad519e183920d278764f42569f56dcee88976 /PKGBUILD
parent5ec83519232bd6d331a490eb84d4b870f6de1f4e (diff)
downloadaur-ogdf-snapshot.tar.gz
Disable GCC 9 errors; Update upstream URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a5eaa7ff54a..4f08cb576144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,20 @@
pkgname=('ogdf-snapshot' 'ogdf-snapshot-docs')
pkgver=2018_03_28
-pkgrel=2
+pkgrel=3
pkgdesc="OGDF is a self-contained C++ class library for the automatic layout of diagrams. OGDF offers sophisticated algorithms and data structures to use within your own applications or scientific projects."
arch=('i686' 'x86_64')
-url="http://amber-v7.cs.tu-dortmund.de/doku.php/start"
+url="https://ogdf.uos.de/"
license=('GPL')
makedepends=('cmake' 'doxygen' 'graphviz' 'bash')
conflicts=('ogdf' 'coin-or-clp' 'coin-or-osi' 'coin-or-coinutils')
-source=("$pkgname-${pkgver//_/-}.zip::http://amber-v7.cs.tu-dortmund.de/lib/exe/fetch.php/tech:$pkgname-${pkgver//_/-}.zip")
+provides=('ogdf')
+source=("$pkgname-${pkgver//_/-}.zip::https://ogdf.uos.de/wp-content/uploads/2019/04/$pkgname-${pkgver//_/-}.zip")
sha256sums=("347c3fa8dcdbb094f9c43008cbc2934bc5a64a532af4d3fe360a5fa54488440f")
build() {
cd "$srcdir/OGDF-snapshot"
- cmake -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${CPPFLAGS} -Wno-class-memaccess -Wno-error=restrict" \
+ cmake -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${CPPFLAGS} -Wno-class-memaccess -Wno-error=restrict -Wno-deprecated-copy -Wno-pessimizing-move -Wno-error=shadow" \
-DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
-DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=true \
-DCMAKE_INSTALL_PREFIX="$pkgdir" .