summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-09-19 23:01:40 +0200
committerbartus2020-09-19 23:01:40 +0200
commit6a7fe0d50ea49577ee331746ae0e60532c7e6c6b (patch)
tree31b0dfb7c3d061fc5b95d61d3e9293ff59c537d8 /PKGBUILD
parent6a42a2d5f14b9bff3e551067299a08b9586929fa (diff)
downloadaur-oidn.tar.gz
Add git-lfs support.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 17 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72a2d68d9c05..a11640acbaca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,19 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+function download_git-lfs {
+ local url dir
+ url=${1#git-lfs+}
+ download_git "$url"
+ dir="$SRCDEST/$(get_filename "$url")"
+ git -C "$dir" lfs install
+ git -C "$dir" lfs fetch
+}
+
+function extract_git-lfs {
+ url=${1/git-lfs/https}
+ extract_git "$url"
+}
+
pkgname=oidn
pkgver=1.2.3
_fragment="#tag=v${pkgver}"
@@ -8,10 +23,10 @@ arch=('x86_64')
url="http://www.openimagedenoise.org/"
license=('Apache')
depends=(intel-tbb python)
-makedepends=(git cmake 'ispc>=1.14')
+makedepends=(git git-lfs cmake 'ispc>=1.14')
source=("${pkgname}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
- "git+https://github.com/OpenImageDenoise/oidn-weights.git"
+ "git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"
)
md5sums=('SKIP'
'SKIP'