summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMasahiro Kitagawa2022-03-09 22:28:02 +0900
committerMasahiro Kitagawa2022-03-09 22:28:02 +0900
commit53f27644aadc7eb36339d8a2866b5eef7381517f (patch)
treed23602465c33fae37633699b7277e229b5cbdc41 /PKGBUILD
downloadaur-omegat-textra-plugin.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd040dc19ee3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Masahiro Kitagawa <arctica0316[at]gmail[dat]com>
+
+pkgname=omegat-textra-plugin
+pkgver=2020.2.2
+pkgrel=1
+pkgdesc="NICT TexTra Machine Translation API plugin for OmegaT"
+arch=('any')
+url="https://github.com/miurahr/${pkgname}/"
+license=('GPL3')
+depends=('omegat')
+options=('!strip')
+source=("https://github.com/miurahr/${pkgname}/releases/download/v2020.2.2/${pkgname}-${pkgver}.zip")
+sha256sums=('97ccbc96a8c1566768a8765cc36388c770bdaa68dcb035b4d779cc784cccd3e4')
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}"/usr/share/java/omegat/plugins/textra
+ cp -a "${pkgname}-${pkgver}"/* "${pkgdir}"/usr/share/java/omegat/plugins/textra
+}