summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Lange2019-10-18 16:08:48 +0200
committerMichael Lass2019-10-18 20:23:58 +0200
commitc698f38d490cf9670b1995534ec202c61aa85214 (patch)
treee0988bf7261741cefec4faa3ee579878af6187f2 /PKGBUILD
parent3b87b12ebfe78d49af20dc544cce956bd3dbf2dd (diff)
downloadaur-c698f38d490cf9670b1995534ec202c61aa85214.tar.gz
update location of extramodules and kernel version determination
extra modules are no longer located in /usr/lib/modules/extramodules-* but in /usr/lib/modules/${_kernelver}/extramodules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f409b72a40b..aaf76a21a807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,8 @@ sha256sums=('b18a654b8224bbefcff4e63ead312da2754aca17943ded60b9475062b506639a')
# Heuristic to determine version of installed kernel
# You can modify this if the heuristic fails
-_extramodules=$(ls -dt /usr/lib/modules/extramodules-* | head -n1)
-_kernelver=$(cat ${_extramodules}/version)
+_kernelver=$(ls -dt /usr/lib/modules/* | head -n1 | cut -d/ -f5)
+_extramodules="/usr/lib/modules/${_kernelver}/extramodules"
prepare() {
cd "${srcdir}/${_srcname}-${pkgver}"